package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)((?:#|0x)(?:[a-f0-9]{3}|[a-f0-9]{6})\b|(?:rgb|hsl)a?\([^\)]*\))`)
var str = `yo #5E81AC and there rgb(50, 186, 86) or even #1364e7 and rgb(242, 48, 84)
style=\"color: rgb(255,0,24)\"
style=\"color: rgb(255, 0, 24)\"
style=\"color: rgba(255, 0, 24, .5)\"
style=\"color: hsla(170, 23%, 25%, 0.2 )\"
style=\"color: #fff\"
style=\"color: #f2ewq\" this isn\'t a color
style=\"color: #F2F2F2\"
style=\"color: 0x00ffff\" This is a color with the \`#\` escaped`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}