$re = '/\d{5}(-\d{4})?/m';
$str = '12345-1000
12345
123451231
12345-123
12345adfe
12345
12345-1234
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);