re = /\d{5}(-\d{4})?/m
str = '12345-1000
12345
123451231
12345-123
12345adfe
12345
12345-1234
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end