import re
regex = re.compile(r"\d{5}(-\d{4})?", flags=re.MULTILINE)
test_str = ("12345-1000\n"
"12345\n"
"123451231\n"
"12345-123\n"
"12345adfe\n\n\n"
"12345\n"
"12345-1234\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")