#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)kak-ukrasit-interer-rakushkami\/[0-9]{2}-[0-9](\/|)"
Local $sString = "kak-ukrasit-interer-rakushkami/32-3/" & @CRLF & _
"kak-ukrasit-interer-rakushkami/35-6/" & @CRLF & _
"kak-ukrasit-interer-rakushkami/35-61" & @CRLF & _
"" & @CRLF & _
"kak-ukrasit-interer-rakushkami/" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")