package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)kak-ukrasit-interer-rakushkami\/[0-9]{2}-[0-9](\/|)`)
var str = `kak-ukrasit-interer-rakushkami/32-3/
kak-ukrasit-interer-rakushkami/35-6/
kak-ukrasit-interer-rakushkami/35-61
kak-ukrasit-interer-rakushkami/
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}