import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "kak-ukrasit-interer-rakushkami\\/[0-9]{2}-[0-9](\\/|)";
final String string = "kak-ukrasit-interer-rakushkami/32-3/\n"
+ "kak-ukrasit-interer-rakushkami/35-6/\n"
+ "kak-ukrasit-interer-rakushkami/35-61\n\n"
+ "kak-ukrasit-interer-rakushkami/\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}