import Foundation
let pattern = #"kak-ukrasit-interer-rakushkami\/[0-9]{2}-[0-9](\/|)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
kak-ukrasit-interer-rakushkami/32-3/
kak-ukrasit-interer-rakushkami/35-6/
kak-ukrasit-interer-rakushkami/35-61
kak-ukrasit-interer-rakushkami/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)