using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<metaData\s+key=""([^""]+)"">((?!<\/metaData>).+)<\/metaData>";
string input = @" <metaDataSet>
<metaData key=""DocName"">mm1266505-20180330195251.txt</metaData>
<metaData key=""TARGET"">Brazil BES</metaData>
<metaData key=""com.ibm.wmqfte.OriginatingUser"">eimb@CORPWEB</metaData>
<metaData key=""com.ibm.wmqfte.OriginatingHost"">B051S317.jci.com</metaData>
<metaData key=""com.ibm.wmqfte.TransferId"">414d512050445053514d513031202020770fbe5aacf88f20</metaData>
<metaData key=""com.ibm.wmqfte.Priority"">0</metaData>
</metaDataSet>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}