import re
regex = re.compile(r"<metaData\s+key=\"([^\"]+)\">((?!<\/metaData>).+)<\/metaData>", flags=re.MULTILINE)
test_str = (" <metaDataSet>\n"
" <metaData key=\"DocName\">mm1266505-20180330195251.txt</metaData>\n"
" <metaData key=\"TARGET\">Brazil BES</metaData>\n"
" <metaData key=\"com.ibm.wmqfte.OriginatingUser\">eimb@CORPWEB</metaData>\n"
" <metaData key=\"com.ibm.wmqfte.OriginatingHost\">B051S317.jci.com</metaData>\n"
" <metaData key=\"com.ibm.wmqfte.TransferId\">414d512050445053514d513031202020770fbe5aacf88f20</metaData>\n"
" <metaData key=\"com.ibm.wmqfte.Priority\">0</metaData>\n"
" </metaDataSet>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")