const regex = /<metaData\s+key="([^"]+)">((?!<\/metaData>).+)<\/metaData>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<metaData\\s+key="([^"]+)">((?!<\\\/metaData>).+)<\\\/metaData>', 'gm')
const str = ` <metaDataSet>
<metaData key="DocName">mm1266505-20180330195251.txt</metaData>
<metaData key="TARGET">Brazil BES</metaData>
<metaData key="com.ibm.wmqfte.OriginatingUser">eimb@CORPWEB</metaData>
<metaData key="com.ibm.wmqfte.OriginatingHost">B051S317.jci.com</metaData>
<metaData key="com.ibm.wmqfte.TransferId">414d512050445053514d513031202020770fbe5aacf88f20</metaData>
<metaData key="com.ibm.wmqfte.Priority">0</metaData>
</metaDataSet>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}