import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<metaData\\s+key=\"([^\"]+)\">((?!<\\/metaData>).+)<\\/metaData>";
final String string = " <metaDataSet>\n"
+ " <metaData key=\"DocName\">mm1266505-20180330195251.txt</metaData>\n"
+ " <metaData key=\"TARGET\">Brazil BES</metaData>\n"
+ " <metaData key=\"com.ibm.wmqfte.OriginatingUser\">eimb@CORPWEB</metaData>\n"
+ " <metaData key=\"com.ibm.wmqfte.OriginatingHost\">B051S317.jci.com</metaData>\n"
+ " <metaData key=\"com.ibm.wmqfte.TransferId\">414d512050445053514d513031202020770fbe5aacf88f20</metaData>\n"
+ " <metaData key=\"com.ibm.wmqfte.Priority\">0</metaData>\n"
+ " </metaDataSet>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}