# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/,(?=(?:[^\(\)]*\([^\(\)]*\))*[^\(\)]*$)/\n/gm;t' <<< "39,'2020-04-24','2020-04-24','(2,3,4,5)','(2,3,4)','(36,43,79)',-1,50000,0"