use strict;
my $str = '39,\'2020-04-24\',\'2020-04-24\',\'(2,3,4,5)\',\'(2,3,4)\',\'(36,43,79)\',-1,50000,0';
my $regex = qr/,(?=(?:[^\(\)]*\([^\(\)]*\))*[^\(\)]*$)/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";