$re = '/,(?=(?:[^\(\)]*\([^\(\)]*\))*[^\(\)]*$)/m';
$str = '39,\'2020-04-24\',\'2020-04-24\',\'(2,3,4,5)\',\'(2,3,4)\',\'(36,43,79)\',-1,50000,0';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;