const regex = /,(?=(?:[^\(\)]*\([^\(\)]*\))*[^\(\)]*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(',(?=(?:[^\\(\\)]*\\([^\\(\\)]*\\))*[^\\(\\)]*$)', 'gm')
const str = `39,'2020-04-24','2020-04-24','(2,3,4,5)','(2,3,4)','(36,43,79)',-1,50000,0`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);