import re
regex = re.compile(r",(?=(?:[^\(\)]*\([^\(\)]*\))*[^\(\)]*$)", flags=re.MULTILINE)
test_str = "39,'2020-04-24','2020-04-24','(2,3,4,5)','(2,3,4)','(36,43,79)',-1,50000,0"
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)