#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(*UCP)-P(.*) -N([\p{Lu}- ]+)(?=[\p{Lu} ]) ([\p{L}- ]*?) ?(\d{2}\.\d{2}\.\d{4})? ?N°Dossier (.+)"
Local $sString = "-PC:\Chemin Fichiers\ -NLE-KING JUNIOR Pierre Jean-Marc 31.07.1967 N°Dossier XYZ:1" & @CRLF & _
"-PC:\Chemin Fichiers\ -NLE-KING JUNIOR 31.07.1967 N°Dossier XYZ:1" & @CRLF & _
"-PC:\Chemin Fichiers\ -NLE-KING JUNIOR Pierre Jean-Marc N°Dossier XYZ:1" & @CRLF & _
"-PC:\Chemin Fichiers\ -NLE-KING JUNIOR N°Dossier XYZ:1" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")