using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(*UCP)-P(.*) -N([\p{Lu}- ]+)(?=[\p{Lu} ]) ([\p{L}- ]*?) ?(\d{2}\.\d{2}\.\d{4})? ?N°Dossier (.+)";
string input = @"-PC:\Chemin Fichiers\ -NLE-KING JUNIOR Pierre Jean-Marc 31.07.1967 N°Dossier XYZ:1
-PC:\Chemin Fichiers\ -NLE-KING JUNIOR 31.07.1967 N°Dossier XYZ:1
-PC:\Chemin Fichiers\ -NLE-KING JUNIOR Pierre Jean-Marc N°Dossier XYZ:1
-PC:\Chemin Fichiers\ -NLE-KING JUNIOR N°Dossier XYZ:1
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}