use strict;
my $str = '-PC:\\Chemin Fichiers\\ -NLE-KING JUNIOR Pierre Jean-Marc 31.07.1967 N°Dossier XYZ:1
-PC:\\Chemin Fichiers\\ -NLE-KING JUNIOR 31.07.1967 N°Dossier XYZ:1
-PC:\\Chemin Fichiers\\ -NLE-KING JUNIOR Pierre Jean-Marc N°Dossier XYZ:1
-PC:\\Chemin Fichiers\\ -NLE-KING JUNIOR N°Dossier XYZ:1
';
my $regex = qr/(*UCP)-P(.*) -N([\p{Lu}- ]+)(?=[\p{Lu} ]) ([\p{L}- ]*?) ?(\d{2}\.\d{2}\.\d{4})? ?N°Dossier (.+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}