import Foundation
let pattern = #"(*UCP)-P(.*) -N([\p{Lu}- ]+)(?=[\p{Lu} ]) ([\p{L}- ]*?) ?(\d{2}\.\d{2}\.\d{4})? ?N°Dossier (.+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
-PC:\Chemin Fichiers\ -NLE-KING JUNIOR Pierre Jean-Marc 31.07.1967 N°Dossier XYZ:1
-PC:\Chemin Fichiers\ -NLE-KING JUNIOR 31.07.1967 N°Dossier XYZ:1
-PC:\Chemin Fichiers\ -NLE-KING JUNIOR Pierre Jean-Marc N°Dossier XYZ:1
-PC:\Chemin Fichiers\ -NLE-KING JUNIOR N°Dossier XYZ:1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)