using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"society6.com.*a72v512a73";
string input = @"https://society6.com/product/wish-you-were-beer200158_clear-case?sku=s6-6456336p56a72v512a73v743";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}