re = /society6.com.*a72v512a73/m
str = 'https://society6.com/product/wish-you-were-beer200158_clear-case?sku=s6-6456336p56a72v512a73v743'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end