package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)society6.com.*a72v512a73`)
var str = `https://society6.com/product/wish-you-were-beer200158_clear-case?sku=s6-6456336p56a72v512a73v743`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}