const regex = /society6.com.*a72v512a73/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('society6.com.*a72v512a73', 'gm')
const str = `https://society6.com/product/wish-you-were-beer200158_clear-case?sku=s6-6456336p56a72v512a73v743`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}