using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div class\=""custom"">(.*?)<\/div>";
string input = @"<div><div class=""custom""><p>TEST</p><div>Another inner div</div><div class=""another-class"">Some text</div></div></div>
<p>Another text</p>
<div><div class=""hello""><div class=""custom another"" data-custom=""test-data""><div>Another inner div</div><p>TEST</p><div class=""another-class"">Some text</div></div></div></div>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}