import re
regex = re.compile(r"<div class\=\"custom\">(.*?)<\/div>")
test_str = ("<div><div class=\"custom\"><p>TEST</p><div>Another inner div</div><div class=\"another-class\">Some text</div></div></div>\n"
"<p>Another text</p>\n"
"<div><div class=\"hello\"><div class=\"custom another\" data-custom=\"test-data\"><div>Another inner div</div><p>TEST</p><div class=\"another-class\">Some text</div></div></div></div>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")