re = /<div class\="custom">(.*?)<\/div>/
str = '<div><div class="custom"><p>TEST</p><div>Another inner div</div><div class="another-class">Some text</div></div></div>
<p>Another text</p>
<div><div class="hello"><div class="custom another" data-custom="test-data"><div>Another inner div</div><p>TEST</p><div class="another-class">Some text</div></div></div></div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end