// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<div class\="custom">(.*?)<\/div>"#).unwrap();
let string = "<div><div class=\"custom\"><p>TEST</p><div>Another inner div</div><div class=\"another-class\">Some text</div></div></div>
<p>Another text</p>
<div><div class=\"hello\"><div class=\"custom another\" data-custom=\"test-data\"><div>Another inner div</div><p>TEST</p><div class=\"another-class\">Some text</div></div></div></div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}