#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<cpf>[0-9]{11})(?<nome>[^\n]{32})(?<end>[^\n]{28})(?<comp>[^\n]{8})(?<cidade>[^\n]{13})(?<uf>[^\n]{2})$"
Local $sString = "12345678912primeiro nome do cliente endereço 1 comp 1 cidade 1 SP" & @CRLF & _
"12345678912segundo nome do cliente endereço 2 comp 2 cidade 2 MG"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")