import Foundation
let pattern = #"^(?<cpf>[0-9]{11})(?<nome>[^\n]{32})(?<end>[^\n]{28})(?<comp>[^\n]{8})(?<cidade>[^\n]{13})(?<uf>[^\n]{2})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
12345678912primeiro nome do cliente endereço 1 comp 1 cidade 1 SP
12345678912segundo nome do cliente endereço 2 comp 2 cidade 2 MG
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)