re = /^(?<cpf>[0-9]{11})(?<nome>[^\n]{32})(?<end>[^\n]{28})(?<comp>[^\n]{8})(?<cidade>[^\n]{13})(?<uf>[^\n]{2})$/m
str = '12345678912primeiro nome do cliente endereço 1 comp 1 cidade 1 SP
12345678912segundo nome do cliente endereço 2 comp 2 cidade 2 MG'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end