$re = '/^(?<cpf>[0-9]{11})(?<nome>[^\n]{32})(?<end>[^\n]{28})(?<comp>[^\n]{8})(?<cidade>[^\n]{13})(?<uf>[^\n]{2})$/m';
$str = '12345678912primeiro nome do cliente endereço 1 comp 1 cidade 1 SP
12345678912segundo nome do cliente endereço 2 comp 2 cidade 2 MG';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);