import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<cpf>[0-9]{11})(?<nome>[^\\n]{32})(?<end>[^\\n]{28})(?<comp>[^\\n]{8})(?<cidade>[^\\n]{13})(?<uf>[^\\n]{2})$";
final String string = "12345678912primeiro nome do cliente endereço 1 comp 1 cidade 1 SP\n"
+ "12345678912segundo nome do cliente endereço 2 comp 2 cidade 2 MG";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}