import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<select id=\\\"c1:swfield\\\" name=\\\"c1\\\">.*?)?<option value=\\\".*?\\\">(.*?)<\\/option>(?:<\\/select>)?";
final String string = "<select id=\"c1:swfield\" name=\"c1\"><option value=\"--\">> All Makes</option>\n"
+ "<option value=\"1167\">Acura</option>\n"
+ "<option value=\"1173\">Alfa Romeo</option>\n"
+ "<option value=\"1564\">Smart</option>\n"
+ "<option value=\"1836\">Speranza</option>\n"
+ "<option value=\"1566\">Ssang Yong</option>\n"
+ "</select>\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}