// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?sm)(?:<select id=\"c1:swfield\" name=\"c1\">.*?)?<option value=\".*?\">(.*?)<\/option>(?:<\/select>)?"#).unwrap();
let string = "<select id=\"c1:swfield\" name=\"c1\"><option value=\"--\">> All Makes</option>
<option value=\"1167\">Acura</option>
<option value=\"1173\">Alfa Romeo</option>
<option value=\"1564\">Smart</option>
<option value=\"1836\">Speranza</option>
<option value=\"1566\">Ssang Yong</option>
</select>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}