# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:<select id=\"c1:swfield\" name=\"c1\">.*?)?<option value=\".*?\">(.*?)<\/option>(?:<\/select>)?"
test_str = ("<select id=\"c1:swfield\" name=\"c1\"><option value=\"--\">> All Makes</option>\n"
"<option value=\"1167\">Acura</option>\n"
"<option value=\"1173\">Alfa Romeo</option>\n"
"<option value=\"1564\">Smart</option>\n"
"<option value=\"1836\">Speranza</option>\n"
"<option value=\"1566\">Ssang Yong</option>\n"
"</select>\n\n")
matches = re.finditer(regex, test_str, re.DOTALL | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.