#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?:a/c|account) no\.?\s+(\w+)"
Local $sString = "bank of india account statement name abcd account no. 123456 account type savings account" & @CRLF & _
"statement for a/c no 11111111 between 16-09-2019 and 16-03-2020" & @CRLF & _
"" & @CRLF & _
"shyam alaspure" & @CRLF & _
"period" & @CRLF & _
"01-12-2019 to 29-02-2020" & @CRLF & _
"cust.reln.no" & @CRLF & _
"XXXXXXXX" & @CRLF & _
"account no" & @CRLF & _
"9XXX99999"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")