import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:a/c|account) no\\.?\\s+(\\w+)";
final String string = "bank of india account statement name abcd account no. 123456 account type savings account\n"
+ "statement for a/c no 11111111 between 16-09-2019 and 16-03-2020\n\n"
+ "shyam alaspure\n"
+ "period\n"
+ "01-12-2019 to 29-02-2020\n"
+ "cust.reln.no\n"
+ "XXXXXXXX\n"
+ "account no\n"
+ "9XXX99999";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}