# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?:a/c|account) no\.?\s+(\w+)"
test_str = ("bank of india account statement name abcd account no. 123456 account type savings account\n"
"statement for a/c no 11111111 between 16-09-2019 and 16-03-2020\n\n"
"shyam alaspure\n"
"period\n"
"01-12-2019 to 29-02-2020\n"
"cust.reln.no\n"
"XXXXXXXX\n"
"account no\n"
"9XXX99999")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.