const regex = new RegExp('\\b(?:a/c|account) no\\.?\\s+(\\w+)', 'gm')
const str = `bank of india account statement name abcd account no. 123456 account type savings account
statement for a/c no 11111111 between 16-09-2019 and 16-03-2020
shyam alaspure
period
01-12-2019 to 29-02-2020
cust.reln.no
XXXXXXXX
account no
9XXX99999`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}