using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:a/c|account) no\.?\s+(\w+)";
string input = @"bank of india account statement name abcd account no. 123456 account type savings account
statement for a/c no 11111111 between 16-09-2019 and 16-03-2020
shyam alaspure
period
01-12-2019 to 29-02-2020
cust.reln.no
XXXXXXXX
account no
9XXX99999";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}