#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?=\w*[A-Za-z])(?=\w*[0-9])\w{4,}\b"
Local $sString = "hal9" & @CRLF & _
"bet97" & @CRLF & _
"78test" & @CRLF & _
"" & @CRLF & _
"but not" & @CRLF & _
"h4t" & @CRLF & _
"4444" & @CRLF & _
"test" & @CRLF & _
"h1" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")