import re
regex = re.compile(r"\b(?=\w*[A-Za-z])(?=\w*[0-9])\w{4,}\b", flags=re.MULTILINE)
test_str = ("hal9\n"
"bet97\n"
"78test\n\n"
"but not\n"
"h4t\n"
"4444\n"
"test\n"
"h1\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")