re = /\b(?=\w*[A-Za-z])(?=\w*[0-9])\w{4,}\b/m
str = 'hal9
bet97
78test
but not
h4t
4444
test
h1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end