using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?=\w*[A-Za-z])(?=\w*[0-9])\w{4,}\b";
string input = @"hal9
bet97
78test
but not
h4t
4444
test
h1
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}