$re = '/\b(?=\w*[A-Za-z])(?=\w*[0-9])\w{4,}\b/m';
$str = 'hal9
bet97
78test
but not
h4t
4444
test
h1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);