#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(0|[1-9]{1,3})([.,][1-9]{1,3})?$"
Local $sString = "0" & @CRLF & _
"9" & @CRLF & _
"999" & @CRLF & _
"9999" & @CRLF & _
"99999" & @CRLF & _
"0.9" & @CRLF & _
"0.0" & @CRLF & _
"0.99" & @CRLF & _
"0,999" & @CRLF & _
"0.9999" & @CRLF & _
"99,999" & @CRLF & _
"999.999" & @CRLF & _
"9999.999" & @CRLF & _
"999.9999"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")