import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(0|[1-9]{1,3})([.,][1-9]{1,3})?$";
final String string = "0\n"
+ "9\n"
+ "999\n"
+ "9999\n"
+ "99999\n"
+ "0.9\n"
+ "0.0\n"
+ "0.99\n"
+ "0,999\n"
+ "0.9999\n"
+ "99,999\n"
+ "999.999\n"
+ "9999.999\n"
+ "999.9999";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}