// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(0|[1-9]{1,3})([.,][1-9]{1,3})?$").unwrap();
let string = "0
9
999
9999
99999
0.9
0.0
0.99
0,999
0.9999
99,999
999.999
9999.999
999.9999";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}